Purchasing - Features - Versions - Pre-requisites

 

        

Click on the images for detailed information on the specific designPH version. 

BUY NOW from shop.passivehouse.com!

  • After making a purchase of designPH you will receive login credentials to access the initial software download and updates, online manual and other support resources.
  • iPHA members includes affiliate members of the International Passive House Association and also IG Passivhaus Germany and Passivhaus Austria.
  • Proof of current student, staff or institutional status is required to receive a designPH EDU license. Evidence for this will be requested at the time of purchase

 

Feature comparison:

Find more detailed feature comparison here.

You dont know how to get the latest designPH version?

Please make your choice:
I am a new customer
  |  DesignPH 1.1 user (PHPP9)  |  DesignPH 1.0 user (PHPP8)  |  Others

designPH versions:

  designPH DEMO   designPH EDU   designPH PRO
  no PHPP export   PHPP 8.5 PHPP 9    PHPP 8.5 PHPP 9 
v2.0.0 coming soon    

v1.6.0          
v1.5.0    
v1.1.6x (no longer supported)    
 
v1.0.30 (no longer supported)    

 

 

Software pre-requisites:

OS

Microsoft Windows 7, 8.1 or 10 Mac OS X
PHPP Version if you use PHPP 8, please update to PHPP 9
Note: designPH 1.0 versions works exclusively with PHPP 8.5
if you use PHPP 7, please upgrade to PHPP 9
Note: designPH 1.0 versions works exclusively with PHPP 8.5
Spreadsheet To be able to import designPH export files into PHPP 8 and/or PHPP 9, you need a corresponding spreadsheet software. You can get detailed information on that in your current PHPP handbook.
SketchUp
Make or Pro

Google SketchUp 8.0.11751 (8.0 M2) is compatible with designPH 1.0.x/1.1.x/1.5.x.
Note: The "Install Extension" feature in SketchUp is only available from SU 8 maintenance release M2 onwards. For earlier versions no more install of the plugin is provided.

Trimble SketchUp 2013 (Make or Pro) is compatible with designPH 1.0.x/1.1.x/1.5.x.

Trimble SketchUp 2014 (Make or Pro) is compatible with designPH 1.0.x/1.1.x/1.5.x.

Trimble SketchUp 2015 (Make or Pro) is compatible with designPH 1.0.x/1.1.x/1.5.x.

Trimble SketchUp 2016 (Make or Pro) is compatible with designPH 1.1.x/1.5.x.

Trimble SketchUp 2017 (Make or Pro) is compatible with designPH 1.1.x/1.5.x.

Trimble SketchUp 2018 (Pro) is compatible with designPH 1.5.x.

Trimble SketchUp 2019 (Pro) is compatible with designPH 2.0.x.

 

[Download SketchUpall OS & languages].

 

There is no compatibility with Google SketchUp 7 version.

There is no compatibility with SketchUp "Free" (browser-based version) - it does not support any third-party extensions. 

designPH versions 1.0.0 - 1.0.6 are not compatible with Trimble SketchUp 2014 / 2015 and upwards.

designPH version 1.0.20 is not compatible with Trimble SketchUp 2015 and upwards.

designPH versions 1.0.30/1.1.0 are not 100% compatible with Trimble SketchUp 2016 and upwards.

(See also FAQ)